The v5 stable release is now available

Glad to hear it’s working! If you can post details for the errors you’re seeing we can try to help.

We’re currently working on implementing 2FA, it should be available soon. We can add shorter session timeout options.

Feel free to create an issue to request supporting max simultaneous sessions.

XMLHttpRequest error is the error message i get when i out and then try to sign in again…is this normal?

If you’re still having a problem please create a new post and we’ll help you there.

I couldn’t find an update in Softaculous but I tried to fresh install on another domain to test v5. Here are few questions:

  1. How can I add 2Checkout as a payment gateway? This is what I’ve already configured in the previous version 4.
  2. How can I import all of my data from old domain to the new one?
  3. At the bottom left corner it’s showing me error that says “The cron job needs to be done”. I’ve already tried refreshing the data under Device Settings, it’s still there.

Thank you!


  1. They aren’t yet supported but we’ll be adding more gateways in the coming months.
  2. To upgrade from v4 you need to install v5 as a separate app and then use the migration tool in the latest version of v4 on Settings > Account Management.
  3. There’s more info here: Free Open-Source Invoicing, Expenses & Time-Tracking | Invoice Ninja

Oh! In that case I will wait then until it’s totally stable and have all the features that v4 has.

Installed v5 today via Softaculous and I’m still getting plenty bugs. Hopefullt I’m the one missing steps here.

If you’re having problems with the app please create a new post with details about the errors

1 Like

@hillel, I have a question. I gone to the hyperlink that you provided, your version is 5.1.62 and the one that we installed yesterday night twice was 5.1.65 - c48 — should I been using your hyperlink since we are having issues with ours? I have another posting for help regarding uploading files, which you added a post.

Let me know…

I have Apache and Nginx on my Vultr server at Cloudways.

From my understanding, I should be creating a new install location for Version 5 (since my old software is version 4+). However, I’m not clear that I can follow these directions properly for my environment. Free Open-Source Invoicing, Expenses & Time-Tracking | Invoice Ninja

Which directions should I be using exactly?

I’v asked cloudways if I can run the ubuntu sudo commands and they have said I cannot. Even though, my apache runs on ubuntu machine. So I don’t know my alternative ways to install this software.

Is there no way to just manually install the files, create a database and run the setup file or create a .env file?


In general we recommend this guide:


So, cloudways says I can’t run sudo commands on ubuntu. So should I just assume I can’t use invoice ninja v5 because there is no way for me to install it? If thats the case, I guess I’m forced to try and look for something else for my invoicing. :frowning:

I’m not even on a shared server. I pay for my own server. And even then, I can’t even follow these shared server instructions because he’s having the same troubles as me.

Sorry for the delayed response but happy to hear you found a solution!

I have invoice ninja 4 and used it for years. The problem was trying to install freaking version 5 which is completely different. At first I thought I could install it using softactaculus, and although I connected my server fine, it refused to install there using remote softaculus account. I thought I was being smart.

So then I stumbled upon a 3 minute video from the invoice ninja youtube where he clearly just installs the files, even though I read in documents you can’t just ‘install the files and set it up’. Yet, he did it in the video! Why isn’t that mentioned in the documentation? I was beating myself in the head over this. And even here, upon asking, no one told me it was that simple…??

So after WEEKS I simply installed the files and went to /setup and low and behold It seemed I could setup just fine. and I went thru each testing process where I was cleared and connected until I got to the bottom and started to create my account. and then when I submitted ALL the info that was acccepted and working fine, instead of creating my new account on my server, the screen refreshed BACK to the setup page and did not make my account at all. no warning, no errors, just reverted back to the setup page. and it did it twice! I gave up at that point. I just gave up.

I gave in and purchased the pro plan for version 5 on the hosted invoice ninja website and am still having a few issues. I imported my json file from v4 self hosted, to v4 hosted. then migrated that to version 5 and now I’m having weird issues with version 5 I’m trying to solve with the customer service!! I want to pull my hair out.

I’ll try and self host down the road when v5 is much more stable and if it becomes easier to install without all these bugs I see everyone else has with installation too.

All in all, I guess its worth the headache because I do love Invoice ninja when compared with competitors. I"m just curious now…what happened to proposals in version 5?? that was the entire reason I made the switch to invoice ninja in the first place years ago…ugh…

Sorry for the trouble!

If you’re seeing problems with the app please create a new post with details about the issues you’re seeing and we’ll work to correct them.

I am trying to install invoiceninja v5 latest version.(Ubuntu 18) During installation, i choose “log” as driver, then i gave user details. After clicking it is loading nearly for 10 minutes. Then it shows “404 not found” error. In error log it shows ‘db fails’ error. But in .env file, database details are stored correctly and database tables are creating (but inside the table no values are stored)
Can you please help how to solve this problem?

Are there any errors in the web server error logs?

Please create a new post and we’ll try to help.

you are better with v4…this v5 feels like a waste of time…just one small thing and it breaks, forcing you to re-install and reconfig all over again. I was just glancing through the invoice design options after thinking of creating a background for the invoices, i toggled HTML mode for clean and playful in the list in the customize & PREVIEW…after that, noticed the preview were blank, then error 500, loading phantom error etc…now nothing i can do to fix this error. I regret going through the invoice preview…

this error is common as i see many users complaining

1 Like


Any idea when would you guys be able to add 2Checkout Gateway in v5?

1 Like