Testing Release v5.0.10-release


I tried to install the beta on a subdomain for testing. However I can’t get past the first setup screen.
It’s all green but still errors out?

I think there should be a fix for this in the next release.

Sorry for the trouble, Betas are fun :slight_smile:

1 Like

Yeah, same here.

2020-07-06T22:23:51.289063Z 2 [Note] Access denied for user 'ninja'@'%' to database 'ninja'

So I dropped the user and created the user (‘ninja’@’%’) again and database ninja but I can’t get access when I hit the Test Connection button.

Oops, looks like something isn’t correct!

I changed the caddy:alpine environment and app to
also the port to
- "8999:80"

Don’t know what’s wrong:)

It’s the docker (composer) version.

It may help to use 5.0.9 or to wait for 5.0.11

Yeah, I’ll try these and that. I had v4 running but I messed it up (docker). So, now I wanna hop on v5 straightaway.

I just tried zip installation (Release v5.0.12-release). The installation went through but I’m not able to login. Is there any Nginx config available for v5? .env is also still the same? Or is there any important changes for v5 as well?

Now I’m able to login. But I guess I have still some problems with my Nginx config.
Maybe we can compare it with the “right one”?

server {

    listen 8888;

    root /srv/http/invoiceninja-v5/public;
    index index.php index.html index.htm;

    client_max_body_size 100M;

        access_log /var/log/nginx/invoice-ninja.access.log;
        error_log /var/log/nginx/invoice-ninja.error.log;

    location / {
        try_files $uri $uri/ =404;

    if (!-e $request_filename) {
        rewrite ^(.+)$ /index.php?q= last;

    location ~ \.php$ {
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass unix:/var/run/php-fpm/php-fpm.sock;
        fastcgi_index index.php;
        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_intercept_errors off;
        fastcgi_buffer_size 16k;
        fastcgi_buffers 4 16k;


    location ~ /\.ht {
        deny all;

There are no icons.

We have a sample nginx conf here


Could you past the content of the snippets/fastcgi-php.conf file, please?

# regex to split $uri to $fastcgi_script_name and $fastcgi_path
fastcgi_split_path_info ^(.+\.php)(/.+)$;

# Check that the PHP script exists before passing it
try_files $fastcgi_script_name =404;

# Bypass the fact that try_files resets $fastcgi_path_info
# see: http://trac.nginx.org/nginx/ticket/321
set $path_info $fastcgi_path_info;
fastcgi_param PATH_INFO $path_info;

fastcgi_index index.php;
include fastcgi.conf;

This should be a standard snippet in the snippets folder of nginx.