Problem with Mails, Logs, Activities


i’ve installed invoice ninja v5 in self hosted vm. For some reason i got some problems:

  1. E-Mails wont work:
    i changed my .env file.
MAIL_PORT="587"   <-- also tried with 465. 

And i am sure that my mail settings are fine.
an end via tinker (?) is also functionally:

timo@vertrieb:/usr/share/nginx/invoiceninja$ php artisan tinker
Psy Shell v0.11.2 (PHP 7.4.3 — cli) by Justin Hileman
>>> \Mail::raw('hello world', function($message) {
...    $message->subject('Testing email')->to('');
... });
=> null

i also received this test mail from tinker(?).

But when i send an invoice out of invoice ninja, i am not receiving the e-mail. Also there are no new logs in storage/logs/laravel.log (despite of activating API_DEBUG=TRUE)

(also i was searching for a “test e-mail-button” like during the setup → is there an option to test e-mails from invoiceninja page?

  1. Aktivities per Invoice arent loading. The Stuck here:

  2. No new system-log-entries are beeing generated, for this customer i tried to send the invoice:

(Last try: today, 18. Mai 2022)

  1. No new entries in storage/logs/laravel.log except of:
[2022-05-16 06:00:01] production.INFO: Performing Autobilling 2022-05-16 06:00:01  
[2022-05-17 06:00:02] production.INFO: Performing Autobilling 2022-05-17 06:00:02  
[2022-05-18 06:00:01] production.INFO: Performing Autobilling 2022-05-18 06:00:01  

(so looks like crontab ist running)

I tried already:
chmod 777 /usr/share/nginx/invoiceninja -R (my inovice ninja webroot)
chown www-data /usr/share/nginx/invoiceninja -R
chgrp www-data /usr/share/nginx/invoiceninja -R

As root:
php artisan optmize

Does anyone know how to debug this stuff? Or does someone know how to solve that problems?

Screenshot from 3.:


Let’s start with emails, what is QUEUE_CONNECTION set to in the .env? Maybe the queue is enabled but not running. Changing to sync will make it run immediately when sent.

Oh woooow! Did the trick :slight_smile:

timo@vertrieb:/usr/share/nginx/invoiceninja$ cat .env | grep QUE

I had redis as option here. Ist this a wrong setting?

Glad to hear it’s working!

I’m not sure why the value would be set to redis, how did you install the app?

cc @david

Thank you very much :slight_smile:

I followed up this tutorial:

After that i had that feeling that it’s behavior is realy slow. Then i decided to install redis cache (i think i did some failure here). I used some tutorial from google, but cant find it again atm.

Do u have some tipps for me, why my system-log (at customers 2-3 ?) isnt working correct?

To clarify, the systems logs load for some clients but not others?

Are there any errors in the browser console or storagel/logs?

I dont know what happend meanwhile, but my customer logs are loading now.

Thanks for ur help :slight_smile:

But maybe, u can help me with some update problem i got today. I tried to update through the webgui. After that i got this error:

Do u know this one maybe?

It may help to increase the PHP memory limit.

Thank you. That one did the trick :slight_smile: