Need help with PDF generation on Docker install

OK, I have I moved IN on to a new server using docker. Everything works now EXCEPT PDF generation. It is similar to this thread in that the env app_url and the docker .yaml url are somehow out of alignment giving me http errors over https in the browser console. Does anyone have a hint on how the .yaml url & the .env should be populated? Or should I try to set up Nginx on the container to connect securely instead of the current port of 8081?


It may help to set LOCAL_DOWNLOAD=true in the .env settings

Setting LOCAL_DOWNLOAD failed to fix it as I am still getting the same error:

   main.foss.dart.js?v=5.3.29:77624 Mixed Content: The page at '' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ''. This request has been blocked; the content must be served over HTTPS.

I am using Apache to proxy the http from Nginx from the container…

Can you check the APP_URL value is using HTTPS and not HTTP

Nah, same error. It’s funny - when I click "Delivery Note’ the pdf appears!

@david do you have any ideas?


Do you have TRUSTED_PROXIES=* configured in your env file?

I love you David, you too Hillel - it was your LOCAL_DOWNLOADS and the TRUSTED_PROXIES that fixed it! It works - finally. Never give up, never surrender!

One last question. How can I import my data from the broken V5 version to this new Docker version?

Glad to hear it’s working! Maybe you can use the JSON import/export?