Important: automatic mail dispatch does not work

Manual mail sending of an invoice works, but not automatic mail sending for recurring invoices.

The CronJob is set to every minute, but even manual execution does not detect that an invoice should be sent:


php -d register_argc_argv=On /html/invoiceninja/artisan schedule:run
No scheduled commands are ready to run.

Automatic dispatch is activated in the workflow:

After I started the sheduler manually via shell the invoice was generated and sent.
In the meantime I also restarted artisan because of Issue 8031.

As a test, I have now scheduled a new recurring invoice for tomorrow and will observe whether this is automatically generated and sent.

Here is the question:
at what time is the invoice sent (see issue 4917)?

recurring invoices are fired every hour

 $schedule->job(new RecurringInvoicesCron)->hourly()->withoutOverlapping();

In Settings > Email Settings you can set a time for the emails to send and we use the client localization to set the correct offset so your client can receive the email at the designated time.

Thanks for the hint where to set the time.

Does this mean that no distinction is possible between invoice sending and reminder? So all mails are sent at the same time and a distinction as in v4 is no longer possible?

correct, all mail would be sent at the same time.

Issue can be closed. Sending works fine.

However, I found the possibility of v4 better to be able to set different times.