Error 500 after update v5.3.73

Hi there, I just updated from v5.3.68 (just got it working properly after severe api problems)
to v5.3.73 through the UI. Now I get a 500 error on every page. With the following in dev tools console:

/public/:1 Failed to load resource: the server responded with a status of 500 () GET 500
flutter_service_worker.js?v=5.3.68:1 Uncaught (in promise) TypeError: Failed to execute ‘addAll’ on ‘Cache’: Request failed

I tried to clear the cache ?clear_cache=true without succes and also ran php artisan optimize within With the following response:

In Company.php line 29:
Trait “Awobaz\Compoships\Compoships” not found

This is the output of my /storage/logs/laravel.log (this is the last part, it has many of the same logs)

[2022-03-18 10:32:09] production.ERROR: Trait “Awobaz\Compoships\Compoships” not found {“exception”:"[object] (Symfony\Component\ErrorHandler\Error\FatalError(code: 0): Trait “Awobaz\Compoships\Compoships” not found at /home/myuser/
#0 /home/myuser/ Symfony\Component\ErrorHandler\Error\FatalError->__construct(message: '‘Trait "Awobaz\\…’, code: ‘0’, error: '[‘type’ => 1, ‘…’, traceOffset: ‘0’, traceArgs: ‘???’, trace: ‘???’)
#1 /home/myuser/ Illuminate\Foundation\Bootstrap\HandleExceptions->fatalErrorFromPhpError(error: ‘[‘type’ => 1, ‘…’, traceOffset: ‘0’)
#2 /home/myuser/ Illuminate\Foundation\Bootstrap\HandleExceptions->handleShutdown()
#3 /home/myuser/ ()
#4 /home/myuser/ Composer\Autoload\includeFile(file: ‘’/home/myuser…’)
#5 /home/myuser/ Composer\Autoload\ClassLoader->loadClass(class: '‘App\\\\Models\\\\C…’)
#6 /home/myuser/ App\Providers\EventServiceProvider->boot()
#7 /home/myuser/ Illuminate\Container\BoundMethod::Illuminate\Container\{closure:/home/myuser/}()
#8 /home/myuser/ Illuminate\Container\Util::unwrapIfClosure(value: ‘class Closure {…’)
#9 /home/myuser/ Illuminate\Container\BoundMethod::callBoundMethod(container: ‘class Illuminat…’, callback: ‘[0 => class App…’, default: ‘class Closure {…’)
#10 /home/myuser/ Illuminate\Container\BoundMethod::call(container: ‘class Illuminat…’, callback: ‘[0 => class App…’, parameters: ‘[]’, defaultMethod: ‘NULL’)
#11 /home/myuser/ Illuminate\Foundation\Application->call(callback: ‘[0 => class App…’, parameters: ‘???’, defaultMethod: ‘???’)
#12 /home/myuser/ Illuminate\Foundation\Application->bootProvider(provider: ‘class App\\Provi…’)
#13 /home/myuser/ Illuminate\Foundation\Application->Illuminate\Foundation\{closure:/home/myuser/}(p: ‘class App\\Provi…’, ‘35’)
#14 /home/myuser/ array_walk(array: ‘[0 => class Ill…’, callback: ‘class Closure {…’)
#15 /home/myuser/ Illuminate\Foundation\Application->boot()
#16 /home/myuser/ Illuminate\Foundation\Bootstrap\BootProviders->bootstrap(app: ‘class Illuminat…’)
#17 /home/myuser/ Illuminate\Foundation\Application->bootstrapWith(bootstrappers: '[0 => ‘Illumina…’)
#18 /home/myuser/ App\Console\Kernel->bootstrap()
#19 /home/myuser/ App\Console\Kernel->handle(input: ‘class Symfony\\C…’, output: ‘class Symfony\\C…’)
#20 /home/myuser/ {main}()
#21 {main}

1 Like

Just was contacted by a customer with the same error.
After upgrading to 5.3.73, Invoice Ninja doesn’t work anymore → HTTP Error 500.

Running php artisan migrate throws the following error:

PHP Fatal error:  Trait 'Awobaz\Compoships\Compoships' not found in /var/www/invoiceninja5/app/Models/Company.php on line 29

In Company.php line 29:
  Trait 'Awobaz\Compoships\Compoships' not found  

That’s a pretty bad one :unamused:

→ as a side note: Can we disable in-app updates in .env ? So customers don’t update themselves?

@napsty, Any ideas for a solution?

Got Error 500 when upgrading from V5.3.66-W77 to V5.3.71 - #5 by gene mentions a restore. That’s also what I probably have in mind, unless @david or @hillel come up with a quick/hotfix.

@christopherus I downloaded the 5.3.73 zip file and unpacked it on the invoice ninja path, overwriting all existing files. (.env will not overwritten, but make a backup nevertheless).

unzip -d /path/to/invoiceninja5/

Invoice Ninja is now up again for our customer.

But something like this definitely should not happen…


Thank you very much @napsty! That solved my problem. Again, I ran php artisan optimize afterwards. I love InvoiceNinja but I agree with you that this should not happen…

composer update fixed it for me

Yea, I tried that also but no luck… Good it’s solved now.

@christopherus assuming you’re in Europe, you might also be interested in this topic: PDF size sticks to Letter after upgrading to v5.3.73-C77 - #4 by napsty

1 Like

I was able to correct the issue with a work around. Here is my post on the work around

Thanks for sharing @amp51, now we have a few possible solutions in this thread if anyone needs it.

Hi guys,

I’ll try and create more detailed release notes going forward, i’ll link to the documentation on our github wiki here:

1 Like