Bank Transfer (ACH) not working in IN v4

Using latest white label IN v4 and have setup “Bank Transfer” in the Stripe plugin to allow for ACH.

The WebHook URL was added as a webhook endpoint and the following “events” were selected in Stripe:

When trying to use “Bank Transfer” as a payment method on any IN invoice, the initial account data gathering form is presented, asking for name, bank account and bank routing number info. So far so good.

The problem is that the form keeps coming up, even a week after the info was entered and keeps asking for it.

As I missing something to get this to work?

Thank you.


I’m not sure, no one else has reported ACH problems in v4.

You may want to consider upgrading to v5.

Thank for the prompt reply Hillel.

Seems a quick search for “ACH” on this forum shows that indeed others have had issues with ACH in V4 as well.

As for the upgrade, I have attempted the V4 → V5 upgrade 3 times and there were nothing but problems; from being unable to complete the migration, to V5 invoices not going out, to mismatched schedules and dates. I posted about some of that but was told “no idea”, so honestly not eager to try again.

There has to be some logging or other process to ensure ACH works as expected, do you know of any? Maybe specific settings on the Stripe side? Ideally a detailed tutorial I can follow for Stripe ACH integration?

Thank you in advance.

I’m sure there are many ACH posts on the forum however I’m not aware of anyone reporting the specific problem your describing. If you found any please share them with me.

I’m happy to spend time working with you to resolve any problems you’re having with the latest version of the v5 app. Sorry, for v4 I’m not sure what could be the cause of the issue.

One thing I thought of for ACH in Stripe I believe you need to enable it in Stripe, maybe you haven’t done that?

Thank you Hillel, I managed to make it work with help from THIS ticket. Turns out I was not aware the client had to go to the Dashboard and validate the deposits (thanks for flagging that in the ticket), so once done it worked ,and the payment was processed by Stripe.

FYI, I have [Token Billing] set to “Always” in IN v4 as it seems “Opt-In” has the description “box is NOT checked” which seems contradictory and incorrect?!?

Hope using “Always” for [Token Billing] is OK to keep for now, but would like to understand “Opt-In” and “Opt-Out” better if there is any documentation on it…

Thanks again.

And I sincerely appreciate the offer to help me with the migration to v5, I will undertake that again when I have some downtime. Meantime I will renew my V4 license :slight_smile:

1 Like